Package antlr

This package will not be ported to Python 3. We can do without it – see if there is an alternative listed in the notes.

If you think it would be good to port it anyway, get in touch with the upstream!


See antlr in the Fedora Pagure, or go directly to the corresponding spec file.

Fedora X

This is ANTLR 2, quite an old version. Fedora also has antlr3 and antlr4 packages, but it seems Python support is not included in those (?, 2016-03-01).

When porting, the best course of action seems to be switching to ANTLR 4, which has Python 3 support upstream.

RPMs
  • python2-antlr-2.7.7-53.fc28
    • × python(abi) = 2.7
Links

Dependent packages

Run time

None.

Build time

Dependency Tree

Run time

Build time

Project Size

~107K total lines of code
~4.27K (4%) Python
(approximation as of 2.7.7-39.fc23)

Groups

Dependencies

Run time

1 Dropped
Package Upstream Fedora
  python2   X

Build time

1 Python 3 only; 1 Dual support; 1 Dropped
Package Upstream Fedora
  python-setuptools  
  javapackages-tools   🗹
  python2   X