Package ipython

Welcome to the future! This package does not support Python 2 at all. All is good in the world.


See ipython in the Fedora Pagure, or go directly to the corresponding spec file.

Fedora 🗹

Package only supports Python 3

RPMs
  • python3-ipython-6.2.1-1.fc28
    • /usr/bin/python3
    • python(abi) = 3.6
  • python3-ipython-sphinx-6.2.1-1.fc28
    • python(abi) = 3.6
  • python3-ipython-tests-6.2.1-1.fc28
    • /usr/bin/python3
    • python(abi) = 3.6

Dependent packages

Dependency Tree

Dependencies

1 Python 3 only; 19 Released
Package Upstream Fedora
  pytest  
  python-decorator  
  python-ipykernel  
  python-jedi  
  python-jsonschema   bug (CLOSED RAWHIDE)
  python-jupyter-client  
  python-mistune  
  python-nbformat  
  python-nose  
  python-path  
  python-pexpect  
  python-pickleshare  
  python-prompt_toolkit  
  python-setuptools  
  python-simplegeneric  
  python-sphinx  
  python-testpath  
  python-traitlets  
  python-zmq  
  python3   🗹 bug (NEW)