Package koji

This package has some dependencies that do not support Python 3 yet. They need to be ported first. Take a look at the list, and choose one.

(Note that there might be false positives; if you spot one, please file a bug)


See koji in the Fedora Pagure, or go directly to the corresponding spec file.

Fedora I

Lots of the codebase it ported. This includes the Python library. Dependencies that use the library or call koji binaries directly can begin porting.

RPMs
  • koji-1.14.0-1.fc28
    • /usr/bin/python3
  • koji-builder-1.14.0-1.fc28
    • × /usr/bin/python
  • koji-hub-1.14.0-1.fc28
    • × /usr/bin/python
  • koji-utils-1.14.0-1.fc28
    • × /usr/bin/python
  • koji-vm-1.14.0-1.fc28
    • × /usr/bin/python
  • python2-koji-1.14.0-1.fc28
    • × /usr/bin/python
    • × python(abi) = 2.7
  • python2-koji-cli-plugins-1.14.0-1.fc28
    • × python(abi) = 2.7
  • python3-koji-1.14.0-1.fc28
    • python(abi) = 3.6
  • python3-koji-cli-plugins-1.14.0-1.fc28
    • python(abi) = 3.6
Links

Dependent packages

Dependency Tree

Project Size

~100K total lines of code
~72.2K (72%) Python
(approximation as of 1.13.0-3.fc25)

Groups

Dependencies

2 Python 3 only; 15 Released; 1 Blocked; 4 Dropped
Package Upstream Fedora
  python-qpid   I bug (NEW)
  libcomps  
  libvirt-python  
  libxml2  
  mod_wsgi  
  pyOpenSSL  
  python-dateutil  
  python-multilib ? bug
  python-psycopg2  
  python-pycurl  
  python-requests  
  python-requests-kerberos   bug (CLOSED ERRATA)
  python-six   bug (CLOSED CURRENTRELEASE)
  python-sphinx  
  qpid-proton  
  rpm  
  mock   🗹
  python3   🗹 bug (NEW)
  createrepo   X
  python-cheetah   X
  python-krbV   X
  python2   X