Package libssh2-python

We are done! This package is released with Python 3 support, and all is good in the world.


See libssh2-python in the Fedora Pagure, or go directly to the corresponding spec file.

Fedora

Code is old, but it's just a binding: it seems to work with Python 3.4 Should it be renamed python{2,3}-libssh2?

RPMs
  • python2-libssh2-0.7.1-18.fc28
    • × libpython2.7.so.1.0()(64bit)
    • × python(abi) = 2.7
  • python3-libssh2-0.7.1-18.fc28
    • libpython3.6m.so.1.0()(64bit)
    • python(abi) = 3.6
Links

Dependent packages

None.

Dependency Tree

Project Size

~2.04K total lines of code
~24 (1.2%) Python
~2K (99%) C/C++ w/ CPython API
(approximation as of 0.7.1-13.fc25)

Dependencies

1 Python 3 only; 1 Dropped
Package Upstream Fedora
  python3   🗹 bug (NEW)
  python2   X