Package pki-core

This package is released with dual support for Python 2 and Python 3. To move things forward, you can start making dependent packages use the Python 3 version.


See pki-core in the Fedora Pagure, or go directly to the corresponding spec file.

Upstream ?

No information

Links

Fedora

A package that supports Python 3 is in Rawhide.

RPMs
  • pki-server-10.6.1-2.fc29
    • python(abi) = 3.6
  • python2-pki-10.6.1-2.fc29
    • × python(abi) = 2.7
  • python3-pki-10.6.1-2.fc29
    • python(abi) = 3.6

Dependent packages

Run time

Build time

None.

Dependency Tree

Run time

Build time

Project Size

~650K total lines of code
~35.4K (5.4%) Python
(approximation as of 10.4.8-2.fc25)

Groups

Dependencies

Run time

1 Python 3 only; 8 Dual support; 1 Dropped
Package Upstream Fedora
  libselinux  
  policycoreutils   bug (CLOSED RAWHIDE)
  python-cryptography   bug (CLOSED ERRATA)
  python-ldap   bug (CLOSED WONTFIX)
  python-lxml  
  python-nss   bug
  python-requests  
  python-six   bug (CLOSED CURRENTRELEASE)
  python3   bug (NEW)
  python2   X

Build time

1 Python 3 only; 12 Dual support; 1 Idle; 1 Dropped
Package Upstream Fedora
  git (nonblocking)   I
  libselinux  
  policycoreutils   bug (CLOSED RAWHIDE)
  pyflakes  
  pylint  
  python-cryptography   bug (CLOSED ERRATA)
  python-flake8  
  python-ldap   bug (CLOSED WONTFIX)
  python-lxml  
  python-nss   bug
  python-requests  
  python-six   bug (CLOSED CURRENTRELEASE)
  python-sphinx  
  python3   bug (NEW)
  python2   X