Package policycoreutils

This package is released with dual support for Python 2 and Python 3. To move things forward, you can start making dependent packages use the Python 3 version.


See policycoreutils in the Fedora Pagure, or go directly to the corresponding spec file.

Fedora

A package that supports Python 3 is in Rawhide.

RPMs
  • policycoreutils-dbus-2.8-5.fc29
    • /usr/bin/python3
  • policycoreutils-devel-2.8-5.fc29
    • /usr/bin/python3
  • policycoreutils-gui-2.8-5.fc29
    • /usr/bin/python3
    • python(abi) = 3.7
  • policycoreutils-python-utils-2.8-5.fc29
    • /usr/bin/python3
  • policycoreutils-sandbox-2.8-5.fc29
    • /usr/bin/python3
  • python2-policycoreutils-2.8-5.fc29
    • × /usr/bin/python2
    • × python(abi) = 2.7
  • python3-policycoreutils-2.8-5.fc29
    • /usr/bin/python3
    • python(abi) = 3.7
Links

Dependent packages

Run time

Build time

Dependency Tree

Run time

Build time

Project Size

~39.6K total lines of code
~27.8K (70%) Python
(approximation as of 2.6-5.fc25)

Groups

Dependencies

Run time

2 Python 3 only; 7 Dual support; 1 Dropped
Package Upstream Fedora
  audit  
  libselinux  
  libsemanage  
  pygobject3  
  python-IPy  
  python-slip  
  setools  
  openbox ? homepage bug repo
  python3   bug (NEW)
  python2   X

Build time

1 Python 3 only; 1 Dropped
Package Upstream Fedora
  python3   bug (NEW)
  python2   X