Package psi4

Welcome to the future! This package does not support Python 2 at all. All is good in the world.


See psi4 in the Fedora Pagure, or go directly to the corresponding spec file.

Upstream ?

A major porting effort by Robert T. McGibbon was merged.

Fedora

A package that supports Python 3 is in Rawhide.

RPMs
  • psi4-1:1.1-5.add49b9git.fc28
    • /usr/bin/python3.6

Dependent packages

Run time

None.

Build time

None.

Dependency Tree

Run time

Build time

Project Size

~786K total lines of code
~150K (19%) Python
~20.3K (2.6%) C/C++ w/ CPython API
(approximation as of 0.3-5.1881450git.fc23)

Dependencies

Run time

1 Dual support
Package Upstream Fedora
  numpy  

Build time

1 Python 3 only; 2 Dual support
Package Upstream Fedora
  numpy  
  python-sphinx  
  python3   bug (NEW)