Package python-autobahn

This package is released with dual support for Python 2 and Python 3. To move things forward, you can start making dependent packages use the Python 3 version.


See python-autobahn in the Fedora Pagure, or go directly to the corresponding spec file.

Fedora

A package that supports Python 3 is in Rawhide.

RPMs
  • python2-autobahn-18.6.1-1.fc29
    • × python(abi) = 2.7
  • python3-autobahn-18.6.1-1.fc29
    • python(abi) = 3.6

Dependent packages

Run time

Build time

Dependency Tree

Run time

Build time

Dependencies

Run time

1 Python 3 only; 11 Dual support; 2 Dropped
Package Upstream Fedora
  python-cffi  
  python-lz4  
  python-msgpack  
  python-six   bug (CLOSED CURRENTRELEASE)
  python-snappy  
  python-trollius  
  python-twisted   bug (CLOSED ERRATA)
  python-txaio  
  python-ujson  
  python-wsaccel  
  python-zope-interface  
  python3   bug (NEW)
  python-futures   X
  python2   X

Build time

2 Python 3 only; 9 Dual support; 2 Dropped
Package Upstream Fedora
  pytest  
  python-cffi  
  python-flake8  
  python-mock  
  python-pep8  
  python-six   bug (CLOSED CURRENTRELEASE)
  python-trollius  
  python-txaio  
  python-unittest2  
  python3   bug (NEW)
  python3-pytest-asyncio  
  python-futures   X
  python2   X