Package python-magnumclient

The Python 2 subpackage(s) are not required by anything in Fedora. They can be dropped if the maintainer wishes.


See python-magnumclient in the Fedora Pagure, or go directly to the corresponding spec file.

Fedora L

Package with dual support whose Python 2 subpackage(s) aren't needed elsewhere in Fedora

RPMs
  • python-magnumclient-tests-2.3.0-4.fc27 x
    • × python(abi) = 2.7
  • python2-magnumclient-2.3.0-4.fc27
    • × python(abi) = 2.7
  • python3-magnumclient-2.3.0-4.fc27
    • /usr/bin/python3
    • python(abi) = 3.6
  • python3-magnumclient-tests-2.3.0-4.fc27
    • python(abi) = 3.6

Dependent packages

Run time

Build time

Dependency Tree

Run time

Build time

Groups

Dependencies

Run time

1 Python 3 only; 1 Py2 leaf; 12 Dual support; 1 Dropped
Package Upstream Fedora
  babel  
  python-fixtures  
  python-keystoneauth1  
  python-mock  
  python-os-client-config  
  python-oslo-i18n  
  python-oslo-serialization (nonblocking)   bug (CLOSED RAWHIDE)
  python-oslo-utils (nonblocking)   bug (CLOSED RAWHIDE)
  python-prettytable  
  python-requests  
  python-stevedore  
  python-testtools  
  python-magnumclient   L
  python3   bug (NEW)
  python2   X

Build time

1 Python 3 only; 1 Py2 leaf; 13 Dual support; 1 Dropped
Package Upstream Fedora
  python-fixtures  
  python-keystoneauth1  
  python-mock  
  python-oslo-i18n  
  python-oslo-sphinx  
  python-oslo-utils (nonblocking)   bug (CLOSED RAWHIDE)
  python-pbr   bug (CLOSED RAWHIDE)
  python-prettytable  
  python-requests  
  python-setuptools  
  python-sphinx  
  python-stevedore  
  python-testtools  
  python-magnumclient   L
  python3   bug (NEW)
  python2   X