Package python-metakernel

This package is released with dual support for Python 2 and Python 3. To move things forward, you can start making dependent packages use the Python 3 version.


See python-metakernel in the Fedora Pagure, or go directly to the corresponding spec file.

Fedora

A package that supports Python 3 is in Rawhide.

RPMs
  • python2-metakernel-0.20.14-7.fc29
    • × python(abi) = 2.7
  • python2-metakernel-bash-0.19.1-16.fc29
    • × python(abi) = 2.7
  • python2-metakernel-echo-0.19.1-16.fc29
    • × python(abi) = 2.7
  • python2-metakernel-python-0.19.1-16.fc29
    • × python(abi) = 2.7
  • python2-metakernel-tests-0.20.14-7.fc29
    • × python(abi) = 2.7
  • python3-metakernel-0.20.14-7.fc29
    • python(abi) = 3.7
  • python3-metakernel-bash-0.19.1-16.fc29
    • python(abi) = 3.7
  • python3-metakernel-echo-0.19.1-16.fc29
    • python(abi) = 3.7
  • python3-metakernel-python-0.19.1-16.fc29
    • python(abi) = 3.7
  • python3-metakernel-tests-0.20.14-7.fc29
    • python(abi) = 3.7

Dependent packages

Run time

Build time

Dependency Tree

Run time

Build time

Dependencies

Run time

1 Python 3 only; 5 Dual support; 1 Dropped
Package Upstream Fedora
  python-ipykernel  
  python-ipyparallel  
  python-jedi  
  python-nose  
  python-pexpect  
  python3   bug (NEW)
  python2   X

Build time

1 Python 3 only; 8 Dual support; 1 Dropped
Package Upstream Fedora
  python-ipykernel  
  python-ipyparallel  
  python-jedi  
  python-nose  
  python-numpydoc  
  python-pexpect  
  python-sphinx  
  python-sphinx-bootstrap-theme  
  python3   bug (NEW)
  python2   X