Package python-mwclient

This package is released with dual support for Python 2 and Python 3. To move things forward, you can start making dependent packages use the Python 3 version.


See python-mwclient in the Fedora Pagure, or go directly to the corresponding spec file.

Upstream ?

Upstream git has support for py3.3, py3.4, and py3.5 with tox and travis checking this. It is included in mwclient-0.8.

Links

Fedora

A package that supports Python 3 is in Rawhide.

RPMs
  • python2-mwclient-0.9.0-1.fc29
    • × python(abi) = 2.7
  • python3-mwclient-0.9.0-1.fc29
    • python(abi) = 3.6

Dependent packages

Run time

Build time

Dependency Tree

Run time

Build time

Project Size

~1.66K total lines of code
~1.65K (100%) Python
(approximation as of 0.7.2-1.fc23)

Dependencies

Run time

1 Python 3 only; 4 Dual support; 1 Dropped
Package Upstream Fedora
  python-requests  
  python-requests-oauthlib  
  python-simplejson  
  python-six   bug (CLOSED CURRENTRELEASE)
  python3   bug (NEW)
  python2   X

Build time

1 Python 3 only; 13 Dual support; 1 Dropped
Package Upstream Fedora
  pytest  
  python-funcsigs  
  python-mock  
  python-pytest-cache  
  python-pytest-cov  
  python-pytest-pep8  
  python-pytest-runner  
  python-requests  
  python-requests-oauthlib  
  python-responses  
  python-setuptools  
  python-simplejson  
  python-six   bug (CLOSED CURRENTRELEASE)
  python3   bug (NEW)
  python2   X