Package python-oslo-config

This package is released with dual support for Python 2 and Python 3. To move things forward, you can start making dependent packages use the Python 3 version.


See python-oslo-config in the Fedora Pagure, or go directly to the corresponding spec file.

Fedora

A package that supports Python 3 is in Rawhide.

RPMs
  • python2-oslo-config-2:5.2.0-3.fc29
    • × /usr/bin/python2
    • × python(abi) = 2.7
  • python3-oslo-config-2:5.2.0-3.fc29
    • /usr/bin/python3
    • python(abi) = 3.7

Dependent packages

Run time

Build time

Dependency Tree

Run time

Build time

Groups

Dependencies

Run time

1 Python 3 only; 8 Dual support; 1 Dropped
Package Upstream Fedora
  python-debtcollector  
  python-netaddr   bug (CLOSED RAWHIDE)
  python-oslo-i18n  
  python-pbr   bug (CLOSED RAWHIDE)
  python-rfc3986 bug (CLOSED RAWHIDE)
  python-six   bug (CLOSED CURRENTRELEASE)
  python-stevedore  
  PyYAML  
  python3   bug (NEW)
  python2   X

Build time

1 Python 3 only; 12 Dual support; 1 Idle; 1 Dropped
Package Upstream Fedora
  git (nonblocking)   I
  python-fixtures  
  python-netaddr   bug (CLOSED RAWHIDE)
  python-openstackdocstheme  
  python-oslo-i18n  
  python-oslotest  
  python-pbr   bug (CLOSED RAWHIDE)
  python-rfc3986 bug (CLOSED RAWHIDE)
  python-setuptools  
  python-six   bug (CLOSED CURRENTRELEASE)
  python-sphinx  
  python-stevedore  
  PyYAML  
  python3   bug (NEW)
  python2   X