Package python-pyside

This package is released with dual support for Python 2 and Python 3. To move things forward, you can start making dependent packages use the Python 3 version.


See python-pyside in the Fedora Pagure, or go directly to the corresponding spec file.

Fedora

A package that supports Python 3 is in Rawhide.

RPMs
  • python2-pyside-1.2.4-1.fc28
    • × libpython2.7.so.1.0()(64bit)
    • × python(abi) = 2.7
  • python3-pyside-1.2.4-1.fc28
    • libpython3.6m.so.1.0()(64bit)
    • python(abi) = 3.6
Links

Dependent packages

Run time

Build time

Dependency Tree

Run time

Build time

Project Size

~60.3K total lines of code
~13.5K (22%) Python
~5.38K (8.9%) C/C++ w/ CPython API
(approximation as of 1.2.2-9.fc25)

Groups

Dependencies

Run time

1 Python 3 only; 2 Dual support; 1 Dropped
Package Upstream Fedora
  python-pyside   bug (CLOSED RAWHIDE)
  shiboken   bug (CLOSED RAWHIDE)
  python3   bug (NEW)
  python2   X

Build time

1 Python 3 only; 2 Dual support; 1 Dropped
Package Upstream Fedora
  python-pyside   bug (CLOSED RAWHIDE)
  shiboken   bug (CLOSED RAWHIDE)
  python3   bug (NEW)
  python2   X