Package python-scikit-image

This package is released with dual support for Python 2 and Python 3. To move things forward, you can start making dependent packages use the Python 3 version.


See python-scikit-image in the Fedora Pagure, or go directly to the corresponding spec file.

Fedora

A package that supports Python 3 is in Rawhide.

RPMs
  • python2-scikit-image-0.13.0-6.fc29
    • × libpython2.7.so.1.0()(64bit)
    • × python(abi) = 2.7
  • python3-scikit-image-0.13.0-6.fc29
    • libpython3.6m.so.1.0()(64bit)
    • python(abi) = 3.6
  • scikit-image-tools-0.13.0-6.fc29
    • /usr/bin/python3
Links

Dependent packages

Run time

Build time

Dependency Tree

Run time

Build time

Project Size

~548K total lines of code
~34.5K (6.3%) Python
~506K (92%) C/C++ w/ CPython API
(approximation as of 0.11.3-6.fc23)

Dependencies

Run time

1 Python 3 only; 5 Dual support; 1 Dropped
Package Upstream Fedora
  python-networkx  
  python-pillow  
  python-pywt  
  python-six   bug (CLOSED CURRENTRELEASE)
  scipy  
  python3   🗹 bug (NEW)
  python2   X

Build time

1 Python 3 only; 8 Dual support; 1 Idle; 1 Dropped
Package Upstream Fedora
  python-matplotlib (nonblocking)   I
  numpy  
  python-networkx  
  python-nose  
  python-pillow  
  python-pywt  
  python-setuptools  
  python-six   bug (CLOSED CURRENTRELEASE)
  scipy  
  python3   🗹 bug (NEW)
  python2   X