Package rhn-client-tools

The Python 2 subpackage(s) are not required by anything in Fedora. They can be dropped if the maintainer wishes.


See rhn-client-tools in the Fedora Pagure, or go directly to the corresponding spec file.

Fedora L

Package with dual support whose Python 2 subpackage(s) aren't needed elsewhere in Fedora

RPMs
  • rhn-check-2.7.15-4.fc28
    • /usr/bin/python3
  • rhn-client-tools-2.7.15-4.fc28
    • /usr/bin/python3
  • rhn-setup-2.7.15-4.fc28
    • /usr/bin/python3
  • rhn-setup-gnome-2.7.15-4.fc28
    • × pygtk2
    • × pygtk2 = 2.24.0-21.fc28

Dependent packages

Run time

Build time

None.

Dependency Tree

Run time

Build time

Project Size

~9.82K total lines of code
~9.35K (95%) Python
(approximation as of 2.4.11-1.fc23)

Dependencies

Run time

1 Python 3 only; 1 Py2 leaf; 7 Dual support; 2 Dropped
Package Upstream Fedora
  dbus-python  
  newt  
  pygobject3  
  python-dmidecode  
  python-netifaces  
  rhnlib   bug (CLOSED NEXTRELEASE)
  rpm   bug (CLOSED RAWHIDE)
  python-hwdata   L
  dnf-plugin-spacewalk   🗹 bug (CLOSED ERRATA)
  gnome-python2   X
  pygtk2   X

Build time

2 Dual support; 1 Dropped
Package Upstream Fedora
  python-coverage  
  rpm   bug (CLOSED RAWHIDE)
  python2   X