Package rpkg

This package is released with dual support for Python 2 and Python 3. To move things forward, you can start making dependent packages use the Python 3 version.


See rpkg in the Fedora Pagure, or go directly to the corresponding spec file.

Fedora

A package that supports Python 3 is in Rawhide.

RPMs
  • python2-rpkg-1.53-1.fc29
    • × python(abi) = 2.7
  • python3-rpkg-1.53-1.fc29
    • python(abi) = 3.6

Dependent packages

Run time

Build time

Dependency Tree

Run time

Build time

Project Size

~10.7K total lines of code
~10.1K (95%) Python
(approximation as of 1.49-6.fc25)

Groups

Dependencies

Run time

3 Python 3 only; 5 Dual support; 1 Idle; 1 Dropped
Package Upstream Fedora
  koji (nonblocking)   I bug (CLOSED CURRENTRELEASE)
  GitPython  
  python-cccolutils  
  python-pycurl  
  python-six   bug (CLOSED CURRENTRELEASE)
  rpm   bug (CLOSED RAWHIDE)
  mock   🗹
  python3   🗹 bug (NEW)
  rpmlint   🗹
  python2   X

Build time

2 Python 3 only; 10 Dual support; 1 Idle; 1 Dropped
Package Upstream Fedora
  koji (nonblocking)   I bug (CLOSED CURRENTRELEASE)
  GitPython  
  python-cccolutils  
  python-mock  
  python-nose  
  python-openidc-client  
  python-pycurl  
  python-requests  
  python-rpmfluff  
  python-setuptools  
  python-six   bug (CLOSED CURRENTRELEASE)
  python3   🗹 bug (NEW)
  rpmlint   🗹
  python2   X