Package sagemath

This package has some dependencies that do not support Python 3 yet. They need to be ported first. Take a look at the list, and choose one.

(Note that there might be false positives; if you spot one, please file a bug)


See sagemath in the Fedora Package Database, or go directly to the corresponding spec file.

Fedora I

No current activity is recorded

RPMs
  • sagemath-7.4-2.fc26
    • × /usr/bin/python2
  • sagemath-core-7.4-2.fc26
    • × libpython2.7.so.1.0()(64bit)
    • × python(abi) = 2.7
    • × /usr/bin/python
    • × /usr/bin/python2
  • sagemath-notebook-7.4-2.fc26
    • × /usr/bin/python
    • × python(abi) = 2.7
  • sagemath-sagetex-7.4-2.fc26
    • × python(abi) = 2.7

Dependent packages

None.

Dependency Tree

Project Size

~887K total lines of code
~360K (41%) Python
~1.75K (0.2%) C/C++ w/ CPython API
(approximation as of 6.8-2.fc23)

Dependencies

16 Released; 4 Idle; 2 Blocked; 2 Dropped
Package Upstream Fedora
  brial   I
  pynac   I
  python-cvxopt   I
  python-flask-silk   I
  python-flask-autoindex   I
  python-matplotlib (nonblocking)   I
  Cython  
  future  
  python-crypto  
  python-docutils  
  python-flask-babel   bug (CLOSED RAWHIDE)
  python-flask-openid  
  python-pathlib2  
  python-pexpect  
  python-pickleshare  
  python-prompt_toolkit  
  python-six   bug (CLOSED CURRENTRELEASE)
  python-speaklater  
  python-sphinx  
  python-twisted   bug (CLOSED ERRATA)
  python-ZODB3  
  sympy   bug (CLOSED RAWHIDE)
  python-twisted-mail   X
  python2   X