Package koji

This package is released with dual support for Python 2 and Python 3. To move things forward, you can start making dependent packages use the Python 3 version.


This package has Ambiguous Requires (or BuildRequires): it uses unversioned python, rather than python2 or python3, to refer to other packages. The Python version should always be given explicitly.

See koji in the Fedora Pagure, or go directly to the corresponding spec file.

Note

Lots of the codebase it ported. This includes the Python library. Dependencies that use the library or call koji binaries directly can begin porting.

RPMs

  • koji-1.17.0-5.fc31
    • /usr/bin/python3
  • koji-builder-1.17.0-5.fc31
    • × /usr/bin/python2
  • koji-utils-1.17.0-5.fc31
    • /usr/bin/python3
  • koji-vm-1.17.0-5.fc31
    • /usr/bin/python3
  • python2-koji-1.17.0-5.fc31
    • × python(abi) = 2.7
  • python2-koji-cli-plugins-1.17.0-5.fc31
    • × python(abi) = 2.7
  • python3-koji-1.17.0-5.fc31
    • python(abi) = 3.7
  • python3-koji-cli-plugins-1.17.0-5.fc31
    • python(abi) = 3.7
  • python3-koji-hub-1.17.0-5.fc31
  • python3-koji-hub-plugins-1.17.0-5.fc31
  • python3-koji-web-1.17.0-5.fc31

Ambiguous Requires

This package has ambiguous (Build)Requires for:

Links

Groups

Maintainers